import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z]+\\://)?([a-zA-Z0-9\\-\\.]*\\.+[a-zA-Z]*)(:(6553[0-5]|655[0-2]\\d|65[0-4]\\d{2}|6[0-4]\\d{3}|5\\d{4}|[0-9]\\d{0,3}))?(/([a-zA-Z0-9\\-\\._\\?\\,\\'/\\\\\\+&%\\$#\\=~]*)[^\\.\\,\\)\\(\\s]?)?";
final String string = "mail.google.com\n"
+ "google.it\n"
+ "www.mega.co/\n"
+ "http://www.google.it\n"
+ "mail.google.uk/login/auth.html\n"
+ "ftp://docs.python.org:54/login/\n"
+ "google.com:65535\n"
+ "python.info:65536";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}