// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z]+\://)?([a-zA-Z0-9\-\.]*\.+[a-zA-Z]*)(:(6553[0-5]|655[0-2]\d|65[0-4]\d{2}|6[0-4]\d{3}|5\d{4}|[0-9]\d{0,3}))?(/([a-zA-Z0-9\-\._\?\,\'/\\\+&%\$#\=~]*)[^\.\,\)\(\s]?)?").unwrap();
let string = "mail.google.com
google.it
www.mega.co/
http://www.google.it
mail.google.uk/login/auth.html
ftp://docs.python.org:54/login/
google.com:65535
python.info:65536";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}