re = /([a-zA-Z]+\:\/\/)?([a-zA-Z0-9\-\.]*\.+[a-zA-Z]*)(:(6553[0-5]|655[0-2]\d|65[0-4]\d{2}|6[0-4]\d{3}|5\d{4}|[0-9]\d{0,3}))?(\/([a-zA-Z0-9\-\._\?\,\'\/\\\+&%\$#\=~]*)[^\.\,\)\(\s]?)?/
str = 'mail.google.com
google.it
www.mega.co/
http://www.google.it
mail.google.uk/login/auth.html
ftp://docs.python.org:54/login/
google.com:65535
python.info:65536'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end