using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""\s*:\s*)(?<!"")[\d\.]+(?!"")";
string input = @"{
""first_name"": ""sample"",
""last_name"": ""lastname"",
""integer"" : 100,
""another_float"" : 1555.20,
""float"" : 1555.20,
""date"": ""2015-01-01"",
""date"": ""2015-01-01 15:23:51""
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}