use strict;
my $str = '{
"first_name": "sample",
"last_name": "lastname",
"integer" : 100,
"another_float" : 1555.20,
"float" : 1555.20,
"date": "2015-01-01",
"date": "2015-01-01 15:23:51"
}';
my $regex = qr/("\s*:\s*)(?<!")[\d\.]+(?!")/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}