$re = '/("\s*:\s*)(?<!")[\d\.]+(?!")/';
$str = '{
"first_name": "sample",
"last_name": "lastname",
"integer" : 100,
"another_float" : 1555.20,
"float" : 1555.20,
"date": "2015-01-01",
"date": "2015-01-01 15:23:51"
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);