const regex = /("\s*:\s*)(?<!")[\d\.]+(?!")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("\\s*:\\s*)(?<!")[\\d\\.]+(?!")', 'g')
const str = `{
"first_name": "sample",
"last_name": "lastname",
"integer" : 100,
"another_float" : 1555.20,
"float" : 1555.20,
"date": "2015-01-01",
"date": "2015-01-01 15:23:51"
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}