#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:x?[a-h][18]=(?!K)[KNBQR]|O-O(?:-O)?|(?:[a-h]?x)?[a-h](?![18])[1-8]|[KNBQR][a-h]?[1-8]?x?[a-h][1-8])[+#]?[\?\!]{0,2}(?:[\s]\{.*\})?"
Local $sString = "Nb3b2 {dfdfgdfg" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")