const regex = /(?:x?[a-h][18]=(?!K)[KNBQR]|O-O(?:-O)?|(?:[a-h]?x)?[a-h](?![18])[1-8]|[KNBQR][a-h]?[1-8]?x?[a-h][1-8])[+#]?[\?\!]{0,2}(?:[\s]\{.*\})?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:x?[a-h][18]=(?!K)[KNBQR]|O-O(?:-O)?|(?:[a-h]?x)?[a-h](?![18])[1-8]|[KNBQR][a-h]?[1-8]?x?[a-h][1-8])[+#]?[\\?\\!]{0,2}(?:[\\s]\\{.*\\})?', 'g')
const str = `Nb3b2 {dfdfgdfg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}