import re
regex = re.compile(r"(?:x?[a-h][18]=(?!K)[KNBQR]|O-O(?:-O)?|(?:[a-h]?x)?[a-h](?![18])[1-8]|[KNBQR][a-h]?[1-8]?x?[a-h][1-8])[+#]?[\?\!]{0,2}(?:[\s]\{.*\})?")
test_str = ("Nb3b2 {dfdfgdfg\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")