re = /(?:x?[a-h][18]=(?!K)[KNBQR]|O-O(?:-O)?|(?:[a-h]?x)?[a-h](?![18])[1-8]|[KNBQR][a-h]?[1-8]?x?[a-h][1-8])[+#]?[\?\!]{0,2}(?:[\s]\{.*\})?/
str = 'Nb3b2 {dfdfgdfg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end