#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\(\s*(\w+)\s*(\w+)\)"
Local $sString = "(S" & @CRLF & _
" (NP I)" & @CRLF & _
" (VP" & @CRLF & _
" (VP (V shot) (NP (Det an) (N elephant)))" & @CRLF & _
" (PP (P in) (NP (Det my) (N pajamas)))))"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)