using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\s*(\w+)\s*(\w+)\)";
string substitution = @"\1";
string input = @"(S
(NP I)
(VP
(VP (V shot) (NP (Det an) (N elephant)))
(PP (P in) (NP (Det my) (N pajamas)))))";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}