package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\s*(\w+)\s*(\w+)\)`)
var str = `(S
(NP I)
(VP
(VP (V shot) (NP (Det an) (N elephant)))
(PP (P in) (NP (Det my) (N pajamas)))))`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}