re = /\(\s*(\w+)\s*(\w+)\)/
str = '(S
(NP I)
(VP
(VP (V shot) (NP (Det an) (N elephant)))
(PP (P in) (NP (Det my) (N pajamas)))))'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result