#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x){each\ \$\w+} (?: [^{] | {(?!\/?each) | (?R) )* {\/each}"
Local $sString = "<ul>" & @CRLF & _
" {each $nestedArr}" & @CRLF & _
" <li>{$group}</li>" & @CRLF & _
" " & @CRLF & _
" <ul>" & @CRLF & _
" {each $user}" & @CRLF & _
" <li>{$name}</li>" & @CRLF & _
" {/each}" & @CRLF & _
" </ul>" & @CRLF & _
"" & @CRLF & _
" {/each}" & @CRLF & _
"</ul>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")