const regex = /{each\ \$\w+} (?: [^{] | {(?!\/?each) | (?R) )* {\/each}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{each\\ \\$\\w+} (?: [^{] | {(?!\\\/?each) | (?R) )* {\\\/each}', '')
const str = `<ul>
{each \$nestedArr}
<li>{\$group}</li>
<ul>
{each \$user}
<li>{\$name}</li>
{/each}
</ul>
{/each}
</ul>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}