import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{each\\ \\$\\w+\\} (?: [^\\{] | \\{(?!\\/?each) | (?R) )* \\{\\/each\\}";
final String string = "<ul>\n"
+ " {each $nestedArr}\n"
+ " <li>{$group}</li>\n"
+ " \n"
+ " <ul>\n"
+ " {each $user}\n"
+ " <li>{$name}</li>\n"
+ " {/each}\n"
+ " </ul>\n\n"
+ " {/each}\n"
+ "</ul>";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}