using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{each\ \$\w+} (?: [^{] | {(?!\/?each) | (?R) )* {\/each}";
string input = @"<ul>
{each $nestedArr}
<li>{$group}</li>
<ul>
{each $user}
<li>{$name}</li>
{/each}
</ul>
{/each}
</ul>";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}