#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})(?:\/([0-9]+))?$"
Local $sString = "# ID with optional version number:" & @CRLF & _
"http://regex101.com/r/mH1fN5/123" & @CRLF & _
"http://regex101.com/r/fW0vZ2/456" & @CRLF & _
"" & @CRLF & _
"# ID only" & @CRLF & _
"http://regex101.com/r/yL6jU3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")