package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})(?:\/([0-9]+))?$`)
var str = `# ID with optional version number:
http://regex101.com/r/mH1fN5/123
http://regex101.com/r/fW0vZ2/456
# ID only
http://regex101.com/r/yL6jU3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}