const regex = /^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})(?:\/([0-9]+))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http(?:s?):\\\/\\\/regex101\\.com\\\/r\\\/([a-zA-Z0-9]{1,6})(?:\\\/([0-9]+))?$', 'gm')
const str = `# ID with optional version number:
http://regex101.com/r/mH1fN5/123
http://regex101.com/r/fW0vZ2/456
# ID only
http://regex101.com/r/yL6jU3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}