$re = '/^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})(?:\/([0-9]+))?$/m';
$str = '# ID with optional version number:
http://regex101.com/r/mH1fN5/123
http://regex101.com/r/fW0vZ2/456
# ID only
http://regex101.com/r/yL6jU3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);