#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^(?!(?:.*?\d){6})(.+)$"
Local $sString = "При проверке регулярное выражение не должно пропускать не более 6 цифр" & @CRLF & _
"" & @CRLF & _
"^(?!.*[0-9|\s]{6})(.*)$" & @CRLF & _
"" & @CRLF & _
"не пропускает" & @CRLF & _
"" & @CRLF & _
"123456" & @CRLF & _
"12345 6" & @CRLF & _
"" & @CRLF & _
"но почему то пропускает" & @CRLF & _
"" & @CRLF & _
"12345aa6" & @CRLF & _
"" & @CRLF & _
"12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")