import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:.*?\\d){6})(.+)$";
final String string = "При проверке регулярное выражение не должно пропускать не более 6 цифр\n\n"
+ "^(?!.*[0-9|\\s]{6})(.*)$\n\n"
+ "не пропускает\n\n"
+ "123456\n"
+ "12345 6\n\n"
+ "но почему то пропускает\n\n"
+ "12345aa6\n\n"
+ "12345";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}