$re = '/^(?!(?:.*?\d){6})(.+)$/mu';
$str = 'При проверке регулярное выражение не должно пропускать не более 6 цифр
^(?!.*[0-9|\\s]{6})(.*)$
не пропускает
123456
12345 6
но почему то пропускает
12345aa6
12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);