using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:.*?\d){6})(.+)$";
string input = @"При проверке регулярное выражение не должно пропускать не более 6 цифр
^(?!.*[0-9|\s]{6})(.*)$
не пропускает
123456
12345 6
но почему то пропускает
12345aa6
12345";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}