package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z\u00C0-\u00ff]{2,}(?: [a-zA-Z\u00C0-\u00ff]+){2,20}$`)
var str = `asd
asd
asd asd
asd asd asd
asd asd2 asd
asd2 asd asd
asd asd asd2
asd asd asd asd asd asd
asd asd asd asd asd asd asd asd asd asd asd asd
asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd
joao da silva
josé da silva
josé joão da silva
josé joão josé
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}