import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z\\u00C0-\\u00ff]{2,}(?: [a-zA-Z\\u00C0-\\u00ff]+){2,20}$";
final String string = "asd\n"
+ "asd\n"
+ "asd asd\n"
+ "asd asd asd\n"
+ "asd asd2 asd\n"
+ "asd2 asd asd\n"
+ "asd asd asd2\n"
+ "asd asd asd asd asd asd\n"
+ "asd asd asd asd asd asd asd asd asd asd asd asd\n"
+ "asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd\n"
+ "joao da silva\n"
+ "josé da silva\n"
+ "josé joão da silva\n"
+ "josé joão josé\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}