$re = '/^[a-zA-Z\u00C0-\u00ff]{2,}(?: [a-zA-Z\u00C0-\u00ff]+){2,20}$/m';
$str = 'asd
asd
asd asd
asd asd asd
asd asd2 asd
asd2 asd asd
asd asd asd2
asd asd asd asd asd asd
asd asd asd asd asd asd asd asd asd asd asd asd
asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd asd
joao da silva
josé da silva
josé joão da silva
josé joão josé
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);