using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?=<\/a>)";
string input = @"<div class=""abc"">
<a href=""www...."" title=""aaaaa"">TEXTONE</a>
</div>
<div class=""abc"">
<a href=""www...."" title=""bbbb"">TEXTTWO</a>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}