$re = '/\w+(?=<\/a>)/m';
$str = '<div class="abc">
<a href="www...." title="aaaaa">TEXTONE</a>
</div>
<div class="abc">
<a href="www...." title="bbbb">TEXTTWO</a>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);