const regex = /\w+(?=<\/a>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+(?=<\\\/a>)', 'gm')
const str = `<div class="abc">
<a href="www...." title="aaaaa">TEXTONE</a>
</div>
<div class="abc">
<a href="www...." title="bbbb">TEXTTWO</a>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}