using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:http:\/\/|www\.)?(\w+\.(?:com|net)\/directory)$";
string input = @"example.com/directory
http://example.com/directory
www.example.com/directory";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}