$re = '/^(?:http:\/\/|www\.)?(\w+\.(?:com|net)\/directory)$/m';
$str = 'example.com/directory
http://example.com/directory
www.example.com/directory';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);