import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "emailid: [^<]*<([^>]*)";
final String string = "commit 01\n"
+ " emailid: Tests <tests@gmail.com>\n"
+ " Date: Wed Jun 18 12:55:55 2014 +0530\n\n"
+ " details\n\n"
+ " commit 02\n"
+ " emailid: user <user@gmail.com>\n"
+ " Date: Wed Jun 18 12:55:55 2014 +0530\n\n"
+ " location\n"
+ " commit 03\n"
+ " emailid: Tests <tests@gmail.com>\n"
+ " Date: Wed Jun 18 12:55:55 2014 +0530\n\n"
+ " france24\n"
+ " commit 04\n"
+ " emailid: developer <developer@gmail.com>\n"
+ " Date: Wed Jun 18 12:55:55 2014 +0530\n\n"
+ " seloger";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}