import Foundation
let pattern = #"emailid: [^<]*<([^>]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
commit 01
emailid: Tests <tests@gmail.com>
Date: Wed Jun 18 12:55:55 2014 +0530
details
commit 02
emailid: user <user@gmail.com>
Date: Wed Jun 18 12:55:55 2014 +0530
location
commit 03
emailid: Tests <tests@gmail.com>
Date: Wed Jun 18 12:55:55 2014 +0530
france24
commit 04
emailid: developer <developer@gmail.com>
Date: Wed Jun 18 12:55:55 2014 +0530
seloger
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)