$re = '/emailid: [^<]*<([^>]*)/';
$str = 'commit 01
emailid: Tests <tests@gmail.com>
Date: Wed Jun 18 12:55:55 2014 +0530
details
commit 02
emailid: user <user@gmail.com>
Date: Wed Jun 18 12:55:55 2014 +0530
location
commit 03
emailid: Tests <tests@gmail.com>
Date: Wed Jun 18 12:55:55 2014 +0530
france24
commit 04
emailid: developer <developer@gmail.com>
Date: Wed Jun 18 12:55:55 2014 +0530
seloger';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);