import re
regex = re.compile(r"emailid: [^<]*<([^>]*)")
test_str = ("commit 01\n"
" emailid: Tests <tests@gmail.com>\n"
" Date: Wed Jun 18 12:55:55 2014 +0530\n\n"
" details\n\n"
" commit 02\n"
" emailid: user <user@gmail.com>\n"
" Date: Wed Jun 18 12:55:55 2014 +0530\n\n"
" location\n"
" commit 03\n"
" emailid: Tests <tests@gmail.com>\n"
" Date: Wed Jun 18 12:55:55 2014 +0530\n\n"
" france24\n"
" commit 04\n"
" emailid: developer <developer@gmail.com>\n"
" Date: Wed Jun 18 12:55:55 2014 +0530\n\n"
" seloger")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")