#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[\s\.\,\!\?\"\;\:]|^)(?=[A-Za-z']*?[bcdfghj-np-tvwxyzBCDFGHJ-NP-TVWXYZ])(?=[A-Za-z']*?[aeiouyAEIOUY'])(?:[A-Za-z](?:'?[A-Za-z]){2}|(?:'?[A-Za-z]){2}[A-Za-z])\b'?(?=[\s\.\,\!\?\"\;\:]|$)"
Local $sString = "This regex matches any three letter string that has at least one vowel and at least one consonant. As you can see, it's very effective and it only matches 3 letter words." & @CRLF & _
"The word "I'll" should count as a 3 letter word. Words like "isn't," "you'dn't've," and "let's" shouldn't. Jo's dog is smart. The quick brown dog jumped over the lazy fox." & @CRLF & _
"The qis' house. "qis'" is just a made up word to test stuff like "kids'" but for 3 letters." & @CRLF & _
"" & @CRLF & _
"asd" & @CRLF & _
"'asd" & @CRLF & _
"a'sd" & @CRLF & _
"as'd" & @CRLF & _
"asd'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")