import re
regex = re.compile(r"(?<=[\s\.\,\!\?\"\;\:]|^)(?=[A-Za-z']*?[bcdfghj-np-tvwxyzBCDFGHJ-NP-TVWXYZ])(?=[A-Za-z']*?[aeiouyAEIOUY'])(?:[A-Za-z](?:'?[A-Za-z]){2}|(?:'?[A-Za-z]){2}[A-Za-z])\b'?(?=[\s\.\,\!\?\"\;\:]|$)", flags=re.MULTILINE)
test_str = ("This regex matches any three letter string that has at least one vowel and at least one consonant. As you can see, it's very effective and it only matches 3 letter words.\n"
"The word \"I'll\" should count as a 3 letter word. Words like \"isn't,\" \"you'dn't've,\" and \"let's\" shouldn't. Jo's dog is smart. The quick brown dog jumped over the lazy fox.\n"
"The qis' house. \"qis'\" is just a made up word to test stuff like \"kids'\" but for 3 letters.\n\n"
"asd\n"
"'asd\n"
"a'sd\n"
"as'd\n"
"asd'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")