import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\\s\\.\\,\\!\\?\\\"\\;\\:]|^)(?=[A-Za-z']*?[bcdfghj-np-tvwxyzBCDFGHJ-NP-TVWXYZ])(?=[A-Za-z']*?[aeiouyAEIOUY'])(?:[A-Za-z](?:'?[A-Za-z]){2}|(?:'?[A-Za-z]){2}[A-Za-z])\\b'?(?=[\\s\\.\\,\\!\\?\\\"\\;\\:]|$)";
final String string = "This regex matches any three letter string that has at least one vowel and at least one consonant. As you can see, it's very effective and it only matches 3 letter words.\n"
+ "The word \"I'll\" should count as a 3 letter word. Words like \"isn't,\" \"you'dn't've,\" and \"let's\" shouldn't. Jo's dog is smart. The quick brown dog jumped over the lazy fox.\n"
+ "The qis' house. \"qis'\" is just a made up word to test stuff like \"kids'\" but for 3 letters.\n\n"
+ "asd\n"
+ "'asd\n"
+ "a'sd\n"
+ "as'd\n"
+ "asd'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}