const regex = /(?<=[\s\.\,\!\?\"\;\:]|^)(?=[A-Za-z']*?[bcdfghj-np-tvwxyzBCDFGHJ-NP-TVWXYZ])(?=[A-Za-z']*?[aeiouyAEIOUY'])(?:[A-Za-z](?:'?[A-Za-z]){2}|(?:'?[A-Za-z]){2}[A-Za-z])\b'?(?=[\s\.\,\!\?\"\;\:]|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[\\s\\.\\,\\!\\?\\"\\;\\:]|^)(?=[A-Za-z\']*?[bcdfghj-np-tvwxyzBCDFGHJ-NP-TVWXYZ])(?=[A-Za-z\']*?[aeiouyAEIOUY\'])(?:[A-Za-z](?:\'?[A-Za-z]){2}|(?:\'?[A-Za-z]){2}[A-Za-z])\\b\'?(?=[\\s\\.\\,\\!\\?\\"\\;\\:]|$)', 'gm')
const str = `This regex matches any three letter string that has at least one vowel and at least one consonant. As you can see, it's very effective and it only matches 3 letter words.
The word "I'll" should count as a 3 letter word. Words like "isn't," "you'dn't've," and "let's" shouldn't. Jo's dog is smart. The quick brown dog jumped over the lazy fox.
The qis' house. "qis'" is just a made up word to test stuff like "kids'" but for 3 letters.
asd
'asd
a'sd
as'd
asd'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}