package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)TdxBar[\s\S]+TAction`)
var str = `pnlVisao: TPanel;
tbToolBar: TdxBar;
btnCancelar: TButton;
actAbrir: TAction;
pnlVisao: TPanel;
tbToolBar: TdxBar;
btnCancelar: TButton;
actAbrir: TAction;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}