$re = '/TdxBar[\s\S]+TAction/m';
$str = 'pnlVisao: TPanel;
tbToolBar: TdxBar;
btnCancelar: TButton;
actAbrir: TAction;
pnlVisao: TPanel;
tbToolBar: TdxBar;
btnCancelar: TButton;
actAbrir: TAction;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);