re = /TdxBar[\s\S]+TAction/m
str = 'pnlVisao: TPanel;
tbToolBar: TdxBar;
btnCancelar: TButton;
actAbrir: TAction;
pnlVisao: TPanel;
tbToolBar: TdxBar;
btnCancelar: TButton;
actAbrir: TAction;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end