$re = '/^(?![\W_])((?:([\w-]{2,})\.?){1,})(?<![\W_])@(?![\W_])(?=[\w.-]{5,})(?=.+\..+)((?:([\w-]{2,})\.?){1,})(?<![\W_])$/m';
$str = '# Valid
test@gm.com
test@gmail.com
aa-test@gmail.com
aa_test@gmail.com
aa.test@gmail.com
aa1test@gmail.com
aa1.test@gmail.com
aa1-test@gmail.com
1test@gmail.com
test@gmail.co.in
aa-test@gmail.co.in
aa_test@gmail.co.in
aa.test@gmail.co.in
aa1test@gmail.co.in
aa1.test@gmail.co.in
aa1-test@gmail.co.in
1test@gmail.co.in
# Invalid
test@gmail
.test@gmail.com
-test@gmail.com
_test@gmail.com
tes.t@gmail.com
t.e.st@gmail.com
t.-.est@gmail.com
.test.@gmail.com
test.@gmail.com
test.@.gmail.com
test@.gmail.com
test@.gmail.com.
test@gmail.com.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);