# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?![\W_])((?:([\w-]{2,})\.?){1,})(?<![\W_])@(?![\W_])(?=[\w.-]{5,})(?=.+\..+)((?:([\w-]{2,})\.?){1,})(?<![\W_])$"
test_str = ("# Valid\n"
"test@gm.com\n"
"test@gmail.com\n"
"aa-test@gmail.com\n"
"aa_test@gmail.com\n"
"aa.test@gmail.com\n"
"aa1test@gmail.com\n"
"aa1.test@gmail.com\n"
"aa1-test@gmail.com\n"
"1test@gmail.com\n"
"test@gmail.co.in\n"
"aa-test@gmail.co.in\n"
"aa_test@gmail.co.in\n"
"aa.test@gmail.co.in\n"
"aa1test@gmail.co.in\n"
"aa1.test@gmail.co.in\n"
"aa1-test@gmail.co.in\n"
"1test@gmail.co.in\n\n\n"
"# Invalid \n"
"test@gmail\n"
".test@gmail.com\n"
"-test@gmail.com\n"
"_test@gmail.com\n"
"tes.t@gmail.com\n"
"t.e.st@gmail.com\n"
"t.-.est@gmail.com\n"
".test.@gmail.com\n"
"test.@gmail.com\n"
"test.@.gmail.com\n"
"test@.gmail.com\n"
"test@.gmail.com.\n"
"test@gmail.com.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.