import Foundation
let pattern = #"^(?![\W_])((?:([\w-]{2,})\.?){1,})(?<![\W_])@(?![\W_])(?=[\w.-]{5,})(?=.+\..+)((?:([\w-]{2,})\.?){1,})(?<![\W_])$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Valid
test@gm.com
test@gmail.com
aa-test@gmail.com
aa_test@gmail.com
aa.test@gmail.com
aa1test@gmail.com
aa1.test@gmail.com
aa1-test@gmail.com
1test@gmail.com
test@gmail.co.in
aa-test@gmail.co.in
aa_test@gmail.co.in
aa.test@gmail.co.in
aa1test@gmail.co.in
aa1.test@gmail.co.in
aa1-test@gmail.co.in
1test@gmail.co.in
# Invalid
test@gmail
.test@gmail.com
-test@gmail.com
_test@gmail.com
tes.t@gmail.com
t.e.st@gmail.com
t.-.est@gmail.com
.test.@gmail.com
test.@gmail.com
test.@.gmail.com
test@.gmail.com
test@.gmail.com.
test@gmail.com.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)