#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""[^"]+"|(\$[^$]*\$)"
Local $sString = "$Country$$Country$" & @CRLF & _
"WAN$Country$/$Country$" & @CRLF & _
"$Country$/29" & @CRLF & _
"$Country$/$Country$" & @CRLF & _
""$fdfsrwdrdgf$1$asffdjhk""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")